summaryrefslogtreecommitdiffstats
path: root/src/common/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMichał Zieliński <michal@zielinscy.org.pl>2012-12-27 12:40:58 +0100
committerMichał Zieliński <michal@zielinscy.org.pl>2012-12-27 12:40:58 +0100
commitfb13c0f219282ef888562fb0fcbbeefd915307d4 (patch)
tree52816490c878fc5f57a97e3c2357d934cb70e294 /src/common/test/CMakeLists.txt
parent4e2982d4ddbd4c16793e0adaa96f5bfd6bd9148c (diff)
parentc2ebd5551ff2569f56e3321efd2d9bedaf079955 (diff)
downloadcolobot-fb13c0f219282ef888562fb0fcbbeefd915307d4.tar.gz
colobot-fb13c0f219282ef888562fb0fcbbeefd915307d4.tar.bz2
colobot-fb13c0f219282ef888562fb0fcbbeefd915307d4.zip
Merge branch 'dev-desktop-file' of git://github.com/OdyX/colobot
Diffstat (limited to 'src/common/test/CMakeLists.txt')
-rw-r--r--src/common/test/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/common/test/CMakeLists.txt b/src/common/test/CMakeLists.txt
index 08efdb3..26a31c9 100644
--- a/src/common/test/CMakeLists.txt
+++ b/src/common/test/CMakeLists.txt
@@ -1,7 +1,10 @@
cmake_minimum_required(VERSION 2.8)
-set(CMAKE_BUILD_TYPE debug)
-set(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -Wall -Wold-style-cast -std=gnu++0x")
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE debug)
+endif(NOT CMAKE_BUILD_TYPE)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wold-style-cast -std=gnu++0x")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -O0")
include_directories(
.