summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rw-r--r--src/lib/Server/Plugins/Packages/Collection.py3
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index ca0215858..8791b7b41 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,12 @@
bcfg2 (1.2.3-11) UNRELEASED; urgency=low
+ * Plugins/Packages/Collection: add missing format string parameter
* Client/Tools/APT: save new package version for auto pkgs
* Plugins/Packages: backported get_new_packages
* Plugins/Packages: backported packages_form_entry/_to_entry
* Plugins/PkgVars: new plugin to set various vars per package
- -- Alexander Sulfrian <alex@spline.inf.fu-berlin.de> Fri, 08 Mar 2013 03:43:45 +0100
+ -- Alexander Sulfrian <alex@spline.inf.fu-berlin.de> Sun, 10 Mar 2013 22:23:12 +0100
bcfg2 (1.2.3-9) unstable; urgency=low
diff --git a/src/lib/Server/Plugins/Packages/Collection.py b/src/lib/Server/Plugins/Packages/Collection.py
index 269ce90f5..f417a6c54 100644
--- a/src/lib/Server/Plugins/Packages/Collection.py
+++ b/src/lib/Server/Plugins/Packages/Collection.py
@@ -378,7 +378,8 @@ def factory(metadata, sources, basepath, debug=False):
if len(sclasses) > 1:
logger.warning("Packages: Multiple source types found for %s: %s" %
- ",".join([s.__name__ for s in sclasses]))
+ (metadata.hostname,
+ ", ".join([s.__name__ for s in sclasses])))
cclass = Collection
elif len(sclasses) == 0:
# you'd think this should be a warning, but it happens all the